
Using Raptivity Output with Other Tools 
 

Authoring tools: Articulate Presenter, Authorware, Captivate, Elicitus,  
iSpring Presenter, Lectora, Lectora Snap, Rapid Intake 
ProForm, SoftChalk, Toolbook, Trainersoft 

Presentation tools: Knowledge Presenter, PowerPoint 

Web design tools: Dreamweaver, Flash, FrontPage 

Collaboration tools: Adobe Connect, Breeze 
Course Management tools: Blackboard 

Help documentation tools: Windows Help 
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1. Authoring Tools 
1.1 Using Raptivity output with Articulate Presenter 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Articulate 

Presentations (Version V5) using following simple steps: 

1. Using Raptivity, publish the interactivity as single file output. 

1. Go to the slide in the PowerPoint Presentation on which you wish to include 

     Raptivity interaction. 

2. Go to the menu 'Articulate->Insert Flash Movie...’ 

3. Follow the instruction after clicking the 'Insert Flash Movie...' menu. 

4. Select the display options for the Flash movie as 'Display in slide' and then 

5. Click 'Next'. 

6. Select the Raptivity interaction. To do this, select the path for the flash file output 

    of the interactivity which is present in the 'Publish' directory of the interactivity. 

   Click 'Next'. 

8. Select the option 'Show Flash movie for seconds into the slide'. 

9. Select the option 'Allow player to control inserted Flash movie'. 

10. Select the option 'Set the slide's navigation to advance by user'. Click 'Next'. 

11. Click 'Finish'. 

12. Save the presentation. 

13. Now, to publish the presentation using Articulate, go to the menu 'Articulate- 

     >Publish...' 

14. Select the option 'Web' from left side menu in the Publish frame. 

15. Select the Publish Location as 'Folder'. This will show the default presentation 

       path 

16. In the 'Properties' frame: 

a. Specify the required Published title. 

b. In the 'Presenter:' box select 'Use slide-level presenters'. 

7. Click 'Publish'. This will publish the presentation and launch the presentation in 

    Articulate. 

 
1.2 Using Raptivity output with Authorware 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Authorware 

contents (Version 7.01) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Select Insert > Media > Flash Movie. 



3. In the Flash Asset Properties dialog box, click Browse to select swf file 

4. In the Flash Asset Properties dialog box, verify that Linked, Image, Sound, and 

     Loop are selected as playback options. 

5. In the Scale text box, type 75 for the movie to appear 75 percent of its original 

    size. Click OK. 

6. Double-click the Flash icon to display the Sprite Icon Properties inspector. 

7. Click the Display tab. From the Mode pop-up menu, select Transparent. 

8. Save Knowledge Object 

 
1.3 Using Raptivity output with Captivate 

Note: Follow these instructions for the interactivities published with single file output. 

Option 1 (To open Raptivity interactivity in a new window on button click) 

You can easily create interactivity using Raptivity and include it in your Captivate 

movie slide (version 1.01.1418 and above) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. On a Captivate movie slide, insert one button. A Property dialog box is displayed. 

3. In “On Success” combo box select “Open URL or file”. 

4. Browse .swf file and click OK. 

5. Copy .swf file for launching the interactivity to the location where Captivate 

    movie is saved. 

Option 2 (To open Raptivity interactivity right inside Captivate project) 

You can easily create interactivity using Raptivity and include it right inside your 

Captivate movie slide (version 4) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Select the “Preferences” option from the “Edit” menu. 

3. Select the “Publish Settings” option from “Preferences”. On this screen, select 

     the following two options from “Externalize Resource”. 

a. FMR SWF 

b. Animations 

4. Add the Raptivity Interaction file to the slide and then add the respective “Shell” 

    (See step 5 below for creating shell file) by using the “Animation” option from the 

    “Insert” menu. You can choose to reduce the dimension of the actual Raptivity 

      Interaction on your slide. 

5. To create a Shell file create a new Flash file and add the following code in the 

     first frame of the Actions window. The highlighted part in Yellow needs to be 

    replaced by your Raptivity file name 

    //Create an empty MovieClip and use the MovieClipLoader to load your SWFinto it. 

     var container:MovieClip = createEmptyMovieClip("container", 



    getNextHighestDepth()); container._lockroot = true; var mcLoader:MovieClipLoader =   

   new MovieClipLoader(); mcLoader.addListener(this);  

   mcLoader.loadClip("Flip_Book.SWF",container); function onLoadInit(mc:MovieClip) { 

   mc._lockroot = true; mc._parent._lockroot = true;} 

6. Browse for your Shell file using the following window that should appear after 

    step 4. Select the file you created using step 5. (Note that you need to create as 

    many loader files as your Flash files where each loader file loads a Raptivity 

    Interaction. 

7. Click OK on the “New Animation” window. 

 
1.4 Using Raptivity output with Elicitus 

Raptivity is seamlessly integrated with Elicitus. It is invoked directly from Elicitus 

menu (Insert -> Interactivity). When you publish your Elicitus course, Raptivity 

output is automatically published with the course. 

 
1.5 Using Raptivity output with iSpring Presenter 
Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your presentations. 
1. In Raptivity Publish the Raptivity interactivity as Single Flash File (.swf). 
     Publish the Raptivity interactivity as Single Flash File (.swf). 
2. Open Microsoft PowerPoint® 
3. Click on the iSpring Presenter tab from the menu bar. 
4. Click on the icon ‘flash’. 
5. Select the Raptivity output file & click ‘Open’. 
6. After adding the file(s) click on ‘Publish’. 
7. Under ‘General’ tab select the Local Folder where you want to save the published files. 
8. Click on the tab ‘Playback & Navigation’ and uncheck the box for ‘Advance animations on 
     mouse click’ present under the section ‘Mouse and Keyboard Navigation’. 
9. Click on the tab ‘Advanced’ and select the option ‘Flash movies’ present under the section 
    ‘Detach Media Content’. 
10. Click on ‘Publish’.  
 
1.6 Using Raptivity output with Lectora 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Lectora 

course (version 2004, 2005 and 2006) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. On Lectora page, add Animation control. 

3. Click “Import” button and browse the .swf file. 

4. Click on Ok button. 



5. Publish Lectora’s title using “Publish to HTML” option. 

 

1.7 Using Raptivity output with Lectora Snap 

Note: Follow these instructions for the interactivities published with single file output. 
1. Download the Shell Creator from the following link 
http://ftp.elicitus.com/ftpuser4/ShellCreator.zip 
Username: elicitus4 
Password: Elicitus113 
2. Extract the downloaded zip file. 
3. Execute the ShellCreator.exe from the folder. 
4. C lick on the browse button present at the right hand side. 
5. Select the Raptivity output ( swf file). 
6. Once you are done, press the “Create” button. 
7. You should be prompted with the “Browse For Folder” dialog. Select the appropriate location   
     and press OK to save your Shell file OR make a new folder. 
8. In the folder that you selected, you should find a file with the name ‘Shell.swf’. This folder  
     will also have the Raptivity published file (.swf). 
9. Rename the ‘Shell.swf’ to <Raptivity file name>_Shell.swf 
    Example: If the Raptivity output file is card.swf then shell file name would be card_shell.swf 
10. Open PowerPoint®, Click on the add-in called ‘Lectora Snap’. 
11. Click on the icon ‘Flash’. 
12. Select the shell file ( example card_shell.swf) and click on ‘Open’. 
13. Save and publish the project. 
14. Open the folder in which the Shell files are present and copy the original Raptivity published  
       file (.swf). 
15. Open the Lectora Snap project publish folder and paste the original Raptivity Published file  
       (.swf). 
 
1.8 Using Raptivity output with Rapid Intake ProForm 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Rapid Intake 

Proform (Version 3.0) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Start Rapid Intake ProForm™. 

3. Create a new project by clicking on the Start New  “ProForm Project” option. Fill 

     up the “New Project” form, click on the “OK” button below. 

4. Enter the topic page name and click the button placed in the left bottom corner 

    that tool tips “Add Page or Term”. Fill up the “Add A New Page” form by giving 

    the “Page Title” and select “default (External SWF)” dropdown item from the 

    “Page Type” dropdown. Once done, click “OK”. 

5. Give the title of your interactivity and browse for your Raptivity Interaction by 

http://ftp.elicitus.com/ftpuser4/ShellCreator.zip


clicking on the Folder Image. 

6. Once you select your file, click on the “Advanced” tab on top and select the 

“Raptivity Page?” check box in the “Advanced Page Setting” group. For best size 

in published output, please check the options as shown in the “Resize Settings” 

group. 

NOTE: The “Original Width” and “Original Height” values can differ from Interaction to 

Interaction. To 

check the size of your Raptivity interaction, open the interaction in Raptivity and check the Size. 

7. Once done, you are now ready to publish your Raptivity Interaction to Rapid 

Intake ProForm™. 
 

1.9 Using Raptivity output with SoftChalk 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your SoftChalk lesson 

(Version 6.05.01) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Open SoftChalk and create a new lesson 

3. Click menu ‘Insert ->Media’  

4. Selecting Media will popup up the ‘Insert Media’ window. From this window select 

     option to insert ‘Flash’. 

5. Click ‘Select File’ from above ‘Insert Media’ window to browse for Raptivity published 

     .SWF file. 

6. Selecting the .SWF file will add the file path to the ‘Insert Media’ window.  

7. You can also define the width and height of the ‘.SWF’ file. Using this width and 

     height the ‘.SWF’ file will be added as Flash Media on SoftChalk lesson. 

8. Click OK after selecting the ‘.SWF’ file. You will see the below ‘Flash Movie 

     Placeholder’ added to the screen. 

9. You can also add some extra objects like text, table on this lesson page. 

10. After inserting the required media file, you will have to save the lesson using ‘File -> 

      Save’ or by clicking the save icon on the toolbar 

11. After saving you can click the toolbar button ‘View in Browser’  to view the 

      page. This will open the page in browser and you can see the interactivity added to 

      the page. 

 
1.10 Using Raptivity output with ToolBook 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your ToolBook 



Books (Version 2004) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Open the desired Toolbook book in which the interactivity is to be inserted 

3. Add Push button on the Page. 

4. Right-click the added Push Button and click the „Hyperlink‟ shortcut menu. 

5. Select the option „URL‟ and the enter the .swf file name of Raptivity‟s Published 

output For example: “MyInteractivity.swf” 

6. Click the „OK‟ button on „Hyperlink‟ dialog box. 

7. Publish the book using File -> Publish to Web (Neuron) option. 
 

1.11 Using Raptivity output with Trainersoft 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Trainersoft 

course (Version 8, 2, 1, 0) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Copy Raptivity published output in the folder where the course is to be 

distributed. 

3. Open existing Trainersoft course in which the interactivity is to be inserted. 

4. From Insert -> Media, insert „Flash Media control‟ on the page. 

5. Open „Configure Web Browser Window‟ dialog by right clicking on the 

6. Flash Media control and selecting „Configure‟ context menu. 

7. In URL field type the name of the Raptivity published swf file. 

8. Save Course. 

9. Distribute course to Local Path / CD-ROM by selecting HTML option. 

10. Deploy Trainersoft‟s Distributed output as a web site. 

 

2. Presentation Tools 
2.1 Using Raptivity output with Knowledge Presenter 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Knowledge 

Presenter‟s presentation or lesson (Version 4.5 and above) using following simple 

steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Deploy Raptivity‟s Published output as a web site. 

3. Open Knowledge Presenter presentation in which you want to insert interactivity. 

Go to the step where you want to add the interactivity. 

4. Go to Insert -> MultimediaWeb -> Flash object. 

5. Click on Insert button and in URL enter the .swf path. 



6. To Export -> Go to File -> Export Lesson or Presentation 

7. Select Standard Export for Play back in Internet Browser and click on export 

     button. 

8. Specify the File name and click on Export button. 

 
2.2 Using Raptivity output with PowerPoint 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your MS 

Presentations (Version 2000 and above) using following simple steps: 

1. In Raptivity, ensure that interactivity is published as single file output. 

1. Open the PowerPoint presentation in which you want to add the interactivity. Go 

     to the slide where you want to add the interactivity. 

2. Open the „Control Toolbox‟ if not already opened. You can open it by clicking toplevel 

     menu View -> Toolbars -> Control Toolbox or right-click any toolbar, and 

    then click the Control Toolbox shortcut menu. 

3. From Control Toolbox, click „More Controls‟ icon, and from the drop down list 

    select „Shockwave Flash Object‟. Place the object at desired location on the slide. 

4. Right-click the Shockwave Flash object placed on the slide and then click the 

    “Properties” shortcut menu to display the Properties pane. 

5. In the Properties pane, assign the full path of the .swf file to the „Movie‟ field. 

     E.g. Set the Path as “C:\MySlide\MyAssets\Flashcards.swf”. 

6. Ensure that the “EmbedMovie” and “Playing” options in the properties pane are set 

    to true. 

7. Run the presentation in slide show view. Before running the presentation ensure 

    that the “Playing” option of the shockwave flash object is set to true. 

 

3. Web Design Tools 

3.1 Using Raptivity output with Dreamweaver 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and insert it in Dreamweaver using 

following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Open a HTM document in which interactivity is to be place 

3. Go to Insert -> Media -> Flash 

4. Select the .swf file 

5. Click on Ok button 

6. Browse the html file to see the interactivity 
 



3.2 Using Raptivity output with Flash 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and insert it in Flash using 

following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

1. Copy Raptivity published output in the folder where the flash file (.fla) is present. 

2. Create a movie Clip on a flash stage (Ctrl + F8), where the interactivity is to be 

     loaded and give some instance name to it (For Example: "myMovieClip_mc") 

3. Set the _lockroot property for this movie to true (for example: 

    holder._lockroot=true;) 

4. Load the interactivity .swf file on the movie clip created by using loadMovie 

    (For example: myMovieClip_mc._lockroot = true;  

      loadMovie("FlipBook.swf",myMovieClip_mc) 

5. Go to Publish Settings and set the Local Playback Security option to "Access Local 

     Files only". 

8. Publish the flash file. 

 
3.1 Using Raptivity output with FrontPage 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and insert it in Front Page (version 

2000 and above) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Open the html file for inserting the interactivity. 

3. Go to Insert -> Component -> Hover button 

4. Click on the browse button for selecting the swf file 

5. Click on OK button 

6. Copy the .swf file at the path were html file is saved. 

7. Browse the html file to see the interactivity 
 

4. Collaboration tools 
4.1 Using Raptivity output with Adobe Connect 

Note: Follow these instructions for the interactivities published with single file output 

and you need to have Adobe Presenter® 7.0.2 or higher version installed on your 

machine. 

You can easily create interactivity using Raptivity and include it in your Adobe 

Acrobat Connect® Pro Meeting using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Start Microsoft PowerPoint® and create a new presentation. 



3. Click on the “Adobe Presenter” menu and it will open up the Adobe Presenter® 

    ribbon. On this ribbon, click the “Insert SWF” option and then click the “Insert 

    SWF File” button. 

4. Browse for the Raptivity Interaction Flash file using the Browse Dialogue and 

    press the “Open” button. 

5. Click on the Publish Button on the Adobe Presenter® ribbon. Ensure that you 

    select the “Zip package” option from the Publish window. 

6. Press the Publish button. This will create a .ZIP file at the specified location. 

    Now, to integrate this with Adobe Connect® Meeting Pro, follow the steps below: 

1. Start Adobe Acrobat Connect® Pro Meeting and create a new Meeting. 

2. From the “What do you want to share?” menu, select the “Documents” dropdown 

    and click on the “Select from My Computer” button. 

3. Select the ZIP file that you created with Adobe Presenter®. 

4. Once you select the file and click “Open”, the file will be uploaded to the Adobe 

   Acrobat Connect® Pro Meeting room. 

 
4.2 Using Raptivity output with Breeze 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in your Breeze 

contents and courses (Version 5) using following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Go to Insert flash. 

3. Select the .swf file 
 

5. Course Management tools 
5.1 Using Raptivity output with Blackboard 

Note: Follow these instructions for the interactivities published with single file output. 

You can easily create interactivity using Raptivity and include it in the Course created 

using Blackboard using following simple steps: 

1. In Raptivity, ensure that interactivity is published with as single file output. 

2. Create zip file of the Raptivity Publish Folder. 

3. Create a course in Blackboard LMS. 

4. Open the newly created course. 

5. Now to edit the course documents, click on 'Edit View' link on the top. 

6. Add Item in course documents by clicking on 'Item' link. 

7. Give appropriate name to the Content. 

8. Under content section, Click Browse to attach the content created in step-2. 

9. In the special action, select 'Unpackage this file'. 



10. Select other options as required and click Submit. 

11. On Content actions page, under 'Embedded media information, select the entry 

       point as the .swf file from the list of various available files. 

12. Click on Ok button to save the item in the course document. 

 

6. Help Tools 
6.1 Using Raptivity Published output with Windows help 

Note: Follow these instructions for the interactivities published with single file output. 

Now you can easily create interactivity using Raptivity and include it in your Windows 

help in following simple steps: 

1. In Raptivity, ensure that interactivity is published with single file output. 

2. Create a HTML file say "Flip Book.html" and the following code 

a. <object width="550" height="400"> 

b. <param name="movie" value="Flip Book.swf"> 

c. <embed src="Flip Book.swf" width="550" height="400"> 

d. </embed> 

e. </object> 

2. Save this HTML file. 

3. In HTML Help Workshop add Raptivity‟s published output file .swf in the following 

     way: 

a. Click on Add/Remove topic files 

b. Click on Add button 

c. Browse the folder, which contains the html and related files. 

d. Enter „*.*‟ in the file name to view all files. 

e. Select html and all additional files. 

4. Insert the page under Contents section and assign html file to it. 

5. Save and compile the help project 

 

 


